当前位置: 代码迷 >> Java Web开发 >> Tomcat的起动
  详细解决方案

Tomcat的起动

热度:2854   发布时间:2013-02-25 21:11:15
Tomcat的启动
在MyEclipse中运行web项目时,启动Tomcat,java.lang.UnsupportedClassVersionError: Bad version number in .class file是什么意思??

------解决方案--------------------------------------------------------
造成这种错误的原因是你的支持Tomcat运行的JDK版本与支持application运行的JDK版本不一致导致的.
------解决方案--------------------------------------------------------
你用的jdk什么版本的
------解决方案--------------------------------------------------------
eclipse中compiler的jdk版本和tomcat所用的jdk版本都设置成一致就可以了。具体做法如下:

在Eclipse中的「Window」->「Preferences」->「Java」->「Compiler」->「JDK Compliance level」->「1.4」改成1.4就OK了。(具体用什么版本的根据你的实际情况)
------解决方案--------------------------------------------------------
jdk版本改成1.4
------解决方案--------------------------------------------------------
当前jdk 的版本和工程的JDK的版本不相吻合.
把当前JDK的版本改成和工程使用的JDK版本一致就行了.
具体步骤参照楼上
------解决方案--------------------------------------------------------
class使用的是高版本jdk,而运行的jre却是低版本的
------解决方案--------------------------------------------------------
都设成你的当前安装的JDK版本就OK了吧……
我用Myeclipse就是设成安装的1.6版本就不会出现这个问题了……
  相关解决方案
本站暂不开放注册!
内测阶段只得通过邀请码进行注册!