当前位置: 代码迷 >> Ruby/Rails >> Ruby 源码1.9.0 在win7, vs2010编译有关问题
  详细解决方案

Ruby 源码1.9.0 在win7, vs2010编译有关问题

热度:172   发布时间:2016-05-06 04:23:33.0
Ruby 源码1.9.0 在win7, vs2010编译问题
设置好了环境变量,在用 nmake编译时,出现如下错误:

ruby -I./.. ./../tool/compile_prelude.rb ./../prelude.rb miniprelude.c

'ruby'不是内部命令,也不是可运行的程序

昨天是我编译 1.9.2 p290 是出现类似如下错误:
-I./.. ./../tool/compile_prelude.rb ./../prelude.rb miniprelude.c
'-I'不是内部命令,也不是可运行的程序

这个是makefile哪里错了么?




------解决方案--------------------
装虚拟机吧。win上面不太适合ruby开发,即使你现在过了,后面也有一堆问题
  相关解决方案
本站暂不开放注册!
内测阶段只得通过邀请码进行注册!
 
  • 最近登录:Sat Oct 21 22:13:25 CST 2017
  • 最近登录:Sat Oct 21 22:13:25 CST 2017
  • 最近登录:Sat Oct 21 22:13:25 CST 2017
  • 最近登录:Sat Oct 21 22:13:25 CST 2017
  • 最近登录:Sat Oct 21 22:13:25 CST 2017