当前位置: 代码迷 >> Ruby/Rails >> RoR初学者
  详细解决方案

RoR初学者

热度:124   发布时间:2016-05-06 04:23:51.0
RoR菜鸟求助
我在Windows系统上安装了ruby 1.9.3p0 (2011-10-30) [i386-mingw32],
然后安装了Rails 3.1.2,
因为mysql2 0.3.10没有windows上的对应版本,所以安装了mysql2 (0.3.9 x86-mingw32)。

现在让我很抓狂的是,用rails new xxx -d mysql创建新的工程时,安装过程中总是试图安装mysql2 0.3.10,但mysql2 0.3.10是安装不上的,请问我该如何解决这个问题?如何在创建新工程时让它使用已装的mysql2 0.3.9。



------解决方案--------------------
你试试 rails new xxx --database=mysql
------解决方案--------------------
相信这个
http://hefeng1987-net-163-com.iteye.com/blog/1115274
对你有用.
------解决方案--------------------

mysql (2.8.1 x86-mingw32)
mysql2 (0.2.6 x86-mingw32)


有这两个gem应该不会有问题!
  相关解决方案
本站暂不开放注册!
内测阶段只得通过邀请码进行注册!
 
  • 最近登录:Thu Mar 23 18:18:19 CST 2017
  • 最近登录:Thu Mar 23 18:18:19 CST 2017
  • 最近登录:Thu Mar 23 18:18:19 CST 2017
  • 最近登录:Thu Mar 23 18:18:19 CST 2017
  • 最近登录:Thu Mar 23 18:18:19 CST 2017