当前位置: 代码迷 >> SQL >> sql2008R2 异常 3000 - 3999
  详细解决方案

sql2008R2 异常 3000 - 3999

热度:861   发布时间:2016-05-05 13:35:26.0
sql2008R2 错误 3000 - 3999

 

错误

严重性

是否记录事件

说明(消息正文)

3002

16

否

不能对数据库快照执行 BACKUP 或 RESTORE。

3003

10

否

此 BACKUP WITH DIFFERENTIAL 将基于多个文件备份。在尝试还原此差异备份之前,必须还原所有这些文件备份。

3004

16

否

不能将主文件组作为文件备份进行备份,因为数据库正在使用 SIMPLE 恢复模式。请考虑通过指定 READ_WRITE_FILEGROUPS 来进行部分备份。

3005

10

否

部分差异备份包括只读文件组 '%ls'。在创建基准部分备份时,此文件组是可读写的,但稍后改为只读访问。我们建议您立即创建 '%ls' 文件组的单独文件备份,然后创建新的部分备份,以便为稍后的部分差异备份提供新的基准。

3006

16

否

不允许进行差异备份,因为差异备份将基于多个基准备份。在简单恢复模式中,不允许进行多个基准的差异备份,并且部分差异备份也不允许进行这样的备份。

3007

16

否

不允许对文件或文件组 "%ls" 进行备份,因为它没有联机。可以使用 FILEGROUP 或 FILE 子句执行 BACKUP,以限制在选项中只包括联机数据。

3008

16

否

不支持对指定的设备类型进行备份镜像。

3009

16

否

未能在 msdb 数据库中插入备份或还原历史/详细记录。这可能表明 msdb 数据库有问题。备份/还原操作仍是成功的。

3010

16

否

指定的备份镜像无效。所有镜像必须具有相同数量的成员。

3011

16

否

所有备份设备都必须属于同一大类(例如 DISK 和 TAPE)。

3012

17

否

当 SQL Server 尝试发送差异信息到 SQL 编写器时,VDI 用尽了缓冲区。

3013

16

否

%hs 正在异常终止。

3014

10

否

%hs 成功处理了 %I64d 页,花费 %d.%03d 秒(%d.%03d MB/秒)。

3015

10

否

%hs 尚未实现。

3016

16

否

不允许对文件 '%ls' 进行备份,因为它包含受联机还原顺序约束的页。在进行备份前应先完成还原顺序,或者对备份进行限制以不包含此文件。

3017

16

否

无法打开重新启动检查点文件 '%ls'。出现操作系统错误 '%ls'。请更正此问题,或者不带 RESTART 重新发出该命令。

3018

10

否

找不到重新启动检查点文件 '%ls'。RESTORE 命令将从开始处继续执行,如同未指定 RESTART 一样。

3019

16

否

重新启动检查点文件 '%ls' 来自以前中断的 RESTORE 操作,并且与当前的 RESTORE 命令不一致。重新启动命令必须使用与中断的命令相同的语法,即添加 RESTART 子句。另外,也可以不带 RESTART 子句重新发出当前语句。

3021

16

否

不能在事务内部执行备份或还原操作。

3022

10

否

此备份是读写数据的文件备份,这些数据所在的数据库使用简单恢复模式。只有在计划将文件组设置为只读,并进行差异文件备份时,才可以这样做。有关管理简单恢复模式的只读数据的详细信息,请查阅联机丛书。请具体考虑部分备份的使用方法。

3023

16

否

对数据库的备份、文件操作(如 ALTER DATABASE ADD FILE)以及加密更改必须序列化。请在当前备份或文件操作完成后重新发出该语句。

3024

16

否

只能对 master 数据库执行完整备份。请使用 BACKUP DATABASE 来备份整个 master 数据库。

3025

16

否

缺少数据库名称。请重新发出该语句并在语句中指定有效数据库名称。

3027

16

否

文件组 "%.*ls" 不属于数据库 "%.*ls"。

3028

10

否

重新启动检查点文件 '%ls' 已损坏,将忽略该文件。RESTORE 命令将从开始处继续执行,如同未指定 RESTART 一样。

3031

16

否

选项 '%ls' 与选项 '%ls' 冲突。请删除冲突的选项,然后重新发出该语句。

3032

16

否

此语句不支持一个或多个选项 (%ls)。请查阅文档以了解所支持的选项。

3033

16

否

BACKUP DATABASE 不能用于以紧急模式打开的数据库。

3034

16

否

未选中要处理的文件。您可能选中了一个或多个没有成员的文件组。

3035

16

否

无法执行数据库 "%ls" 的差异备份,因为不存在当前数据库备份。请去掉 WITH DIFFERENTIAL 选项后重新发出 BACKUP DATABASE 以执行数据库的完整备份。

3036

16

否

数据库 "%ls" 处于备用状态(通过执行 RESTORE WITH STANDBY 而设置)下,只有完成整个还原顺序后,才能进行备份。

3038

16

否

文件名 "%ls" 用作备份设备名时无效。请用有效文件名重新发出 BACKUP 语句。

3039

16

否

无法执行文件 '%ls' 的差异备份,因为不存在当前的文件备份。请去掉 WITH DIFFERENTIAL 选项后重新发出 BACKUP DATABASE 命令。

3040

10

否

通知备份复制时出错。备份操作将继续,但应检查复制环境。

3041

16

是

BACKUP 操作未能完成命令 %.*ls。有关详细消息,请查看备份应用程序日志。

3042

10

否

BACKUP WITH CONTINUE_AFTER_ERROR 成功生成了已破坏的数据库的备份。有关所遇到的错误的信息,请参阅 SQL Server 错误日志。

3043

16

否

BACKUP '%ls' 检测到文件 '%ls' 中的页(%d:%d)上存在错误。

3044

16

否

长度为零的设备名无效。请使用有效的设备名重新发出 BACKUP 语句。

3045

16

否

BACKUP 或 RESTORE 需要 NTFS 文件系统才能提供 FILESTREAM 和全文支持。路径 "%.*ls" 不可用。

3046

16

否

遇到了不一致的元数据。唯一可能的备份操作是使用 WITH CONTINUE_AFTER_ERROR 或 NO_TRUNCATE 选项进行结尾日志备份。

3047

16

否

未正确配置 BackupDirectory 注册表项。当未提供完整路径名时,此项应指定存储磁盘备份文件的根路径。此路径还用于定位重新启动检查点文件以进行 RESTORE。

3049

16

否

BACKUP 操作检测到数据库日志损坏。有关详细信息,请查看错误日志。

3050

16

否

SQL Server 无法将有关数据库 '%ls\\%ls' 的数据库文件 '%ls' 的差异信息发送到备份应用程序,因为差异信息太大,内存中容纳不下,尝试使用临时文件失败。

3051

16

否

BACKUP LOG 无法维护数据库 '%ls' 的镜像一致性。数据库镜像已挂起。

3054

16

否

差异文件备份只能包含使用简单恢复模式的数据库的只读数据。请考虑通过指定 READ_WRITE_FILEGROUPS 来进行部分备份。

3055

16

否

备份目标 "%.*ls" 支持 FILESTREAM 文件组。此文件组不能用作备份目标。请使用有效的备份目标重新运行 BACKUP 语句。

3056

16

否

备份操作检测到 FILESTREAM 容器中存在意外的文件。备份操作将继续,并将包括文件 '%ls'。

3057

16

否

设备名称无效。所提供设备名称的长度超出了支持的限度(最大长度为: %d)。请使用有效的设备名重新发出 BACKUP 语句。

3058

10

否

文件或设备名称超出了支持的限制(最大长度为 %d),将被截断: %.*ls。

3098

16

否

由于在请求 '%ls' 之前使用不兼容的结构格式化了媒体,因此无法执行备份。若要追加到此媒体集,可省略 '%ls' 或指定 '%ls'。也可以在 BACKUP 语句中使用 WITH FORMAT 创建新的媒体集。如果对现有媒体集使用 WITH FORMAT,将覆盖其中的所有备份集。

3101

16

否

因为数据库正在使用,所以无法获得对数据库的独占访问权。

3102

16

否

%ls 无法处理数据库 '%ls',因为它正由此会话使用。建议在执行此操作时使用 master 数据库。

3103

16

否

此命令无法启动部分还原顺序。若要启动部分还原顺序,请使用 RESTORE 语句的 WITH PARTIAL 子句,并提供一个备份集,其中至少包含主数据文件的完整副本。不能出于任何其他目的使用 RESTORE 语句的 WITH PARTIAL 子句。

3104

16

否

无法对数据库 '%ls' 运行 RESTORE,因为已将它配置用于数据库镜像。如果希望还原该数据库,则请使用 ALTER DATABASE 删除镜像。

3105

16

否

RESTORE 无法将更多的页还原到文件 '%ls' 中,因为正在还原的页数已达到最大页数(%d)。请按还原顺序完成还原现有页,或者使用 RESTORE FILE 将所有页还原到该文件中。

3106

16

否

文件组 "%ls" 不明确。备份集中的标识与当前在联机数据库中定义的文件组不匹配。若要强制使用备份集中的文件组,请使该数据库脱机,然后重新发出 RESTORE 命令。

3107

16

否

文件 "%ls" 不明确。备份集中的标识与当前在联机数据库中定义的文件不匹配。若要强制使用备份集中的文件,请使该数据库脱机,然后重新发出 RESTORE 命令。

3108

16

否

若要还原 master 数据库,服务器必须以单用户模式运行。有关在单用户模式下启动的信息,请参阅联机丛书中的"如何启动 SQL Server 实例 (sqlservr.exe)"。

3109

16

否

只能通过一个步骤使用完整数据库备份还原并完全恢复 master 数据库。不支持 NORECOVERY、STANDBY 和 STOPAT 等选项。

3110

14

否

用户没有 RESTORE 数据库 '%.*ls' 的权限。

3111

16

否

页 %S_PGID 是无法单独还原的控制页。若要修复此页,必须还原整个文件。

3112

16

否

当服务器处于单用户模式下时,不能还原除 master 数据库之外的任何其他数据库。

3113

16

否

检测到无效数据。

3115

16

否

该数据库正使用简单恢复模式,因而不可能还原读写数据的子集。

3116

16

否

提供的备份不位于该数据库的恢复路径上,无法用于联机文件还原。

3117

16

否

无法还原日志备份或差异备份,因为没有文件可用于前滚。

3118

16

否

数据库 "%ls" 不存在。RESTORE 只能在还原主文件的完整备份或文件备份时创建数据库。

3119

16

否

在计划 RESTORE 语句时发现了问题。以前的消息提供了详细信息。

3120

16

否

不会还原此备份集,因为所有数据都已还原到此备份集所涵盖的时间之前。

3121

16

否

文件 "%ls" 所在的恢复路径与此备份集的应用程序不一致。RESTORE 操作无法继续。

3122

16

否

文件初始化失败。RESTORE 操作无法继续。

3123

16

否

为备份或还原操作指定的数据库名称 '%.*ls' 无效。

3125

16

否

该数据库正使用简单恢复模式。备份中的数据与数据库的当前状态不一致。首先需要还原更多数据,才可以进行恢复。还原在将数据标记为只读之后创建的完整文件备份,或者在还原目标数据的最新基准备份后还原差异文件备份。

3127

16

是

已还原数据库 '%ls' 的文件 '%.*ls' 保留为无效状态,因为该数据库使用的是简单恢复模式,而且该文件被标记为要进行读写访问。因此,只有只读文件才能通过逐段还原进行恢复。

3128

16

否

不支持文件 '%ls' 的页大小(%d)。

3129

16

否

文件 "%ls" 的内容与还原顺序中的转换不一致。可能需要从备份集进行还原。

3130

10

否

选择了文件组 "%ls"。在备份时该文件组的名称为 "%ls"。RESTORE 将对该重命名后的文件组继续操作。

3131

10

否

选择了文件 "%ls"。在备份时该文件组的名称为 "%ls"。RESTORE 将对该重命名后的文件继续操作。

3132

16

否

媒体集有 %d 个媒体簇,但只提供了 %d 个。必须提供所有成员。

3133

16

否

设备 "%ls" 上的卷的序列号为 %d,属于媒体簇 %d,但序列号应为 %d,属于媒体簇 %d。请检查指定的设备和加载的媒体是否正确。

3134

10

是

数据库 '%ls' 的文件 '%ls' 的差异基准属性已重置,因为该文件已从备份还原,而该备份来自有冲突的恢复路径。由于该文件是只读的,并且与数据库的当前状态一致,因此允许执行该还原。将来对此文件进行任何差异备份都将需要新的差异基准。

3135

16

否

文件 '%ls' 中的备份集是由 %hs 创建的,无法用于此还原操作。

3136

16

否

无法还原此差异备份,因为该数据库尚未还原到正确的早期状态。

3137

16

否

无法恢复数据库。可能是因为错误地指定了主名称或快照名称,没有删除所有其他快照,或者缺少文件。

3138

16

否

无法恢复数据库,因为存在 FILESTREAM BLOB。

3139

16

否

对于 master 数据库,不允许还原到快照。

3140

16

否

无法调整文件 '%ls' 的空间分配。

3141

16

否

要还原的数据库先前命名为 '%ls'。请用 WITH REPLACE 选项重新发出该语句,以覆盖数据库 '%ls'。

3142

16

否

无法在已有的 "%ls" 上还原文件 "%ls"。请重新发出 RESTORE 语句,用 WITH REPLACE 来覆盖原先存在的文件,或者用 WITH MOVE 来标识替代位置。

3143

16

否

设备 '%ls' 上的数据集不是 SQL Server 备份集。

3144

16

否

文件 '%.*ls' 未曾备份到设备 '%ls' 上的文件 %d 中。无法从此备份集中还原该文件。

3145

16

否

使用 SIMPLE 恢复模式的数据库不支持 STOPAT 选项。

3147

16

否

不允许对 tempdb 数据库进行备份或还原操作。

3148

16

否

此 RESTORE 语句在当前上下文中无效。仅当数据库处于联机状态时,才为辅助文件组定义 'Recover Data Only' 选项。当数据库处于脱机状态时,不能指定文件组。

3149

16

否

文件或文件组 "%ls" 的状态对要使用的 "Recover Data Only" 选项无效。只能处理处于 OFFLINE 或 RECOVERY_PENDING 状态的辅助文件。

3150

10

否

已成功地还原了 master 数据库。正在关闭 SQL Server。

3151

21

是

无法还原 master 数据库。正在关闭 SQL Server。请检查错误日志,然后重新生成 master 数据库。有关如何重新生成 master 数据库的详细信息,请参阅 SQL Server 联机丛书。

3153

16

否

数据库已完全恢复。

3154

16

否

备份集中的数据库备份与现有的 '%ls' 数据库不同。

3155

16

否

自创建备份集以来,在数据库中添加或除去了一个或多个文件,所以 RESTORE 操作无法继续。

3156

16

否

文件 '%ls' 无法还原为 '%ls'。请使用 WITH MOVE 选项来标识该文件的有效位置。

3159

16

否

尚未备份数据库 "%ls" 的日志尾部。如果该日志包含您不希望丢失的工作,请使用 BACKUP LOG WITH NORECOVERY 备份该日志。请使用 RESTORE 语句的 WITH REPLACE 或 WITH STOPAT 子句来只覆盖该日志的内容。

3161

16

否

主文件不可用。必须还原该文件或用其他方法使之可用。

3163

16

否

事务日志已损坏。必须还原所有的数据文件之后,才能尝试 RESTORE LOG。

3165

16

否

数据库 '%ls' 已还原,但在还原/删除复制时出错。该数据库保留为脱机状态。请参阅 SQL Server 联机丛书中的主题 MSSQL_ENG003165。

3166

16

否

RESTORE DATABASE 无法删除数据库 '%ls'。请删除该数据库,然后重新发出 RESTORE DATABASE 语句。

3167

16

否

RESTORE 无法启动数据库 '%ls'。

3168

16

否

无法还原设备 %ls 上的系统数据库备份,因为创建该数据库的服务器版本(%ls)与此服务器(%ls)的版本不同。

3169

16

否

该数据库是在运行版本 %ls 的服务器上备份的。该版本与此服务器(运行版本 %ls)不兼容。请在支持该备份的服务器上还原该数据库,或者使用与此服务器兼容的备份。

3170

16

否

STANDBY 文件名无效。

3171

16

否

文件 %ls 不起作用,无法还原到联机数据库中。

3172

16

否

文件组 %ls 不起作用,无法还原到联机数据库中。

3173

16

否

与此 RESTORE 语句一起提供的 STOPAT 子句指示日志的尾部包含要恢复目标时间点的状态而必须备份的更改信息。尚未备份数据库 "%ls" 的日志尾部。请使用 BACKUP LOG WITH NORECOVERY 备份该日志,或使用 RESTORE 语句的 WITH REPLACE 子句来覆盖该日志的尾部。

3174

16

否

此 RESTORE 操作无法移动文件 '%ls'。

3175

10

否

指定了 RESTORE FILEGROUP="%ls",但备份集中不存在该文件组的所有文件。缺少文件 "%ls"。RESTORE 将继续,但如果要还原所有文件,必须还原其他备份集。

3176

16

否

'%ls'(%d)和 '%ls'(%d)要求使用文件 '%ls'。WITH MOVE 子句可用于重新定位一个或多个文件。

3178

16

否

文件 %ls 未处于可应用此差异备份的正确状态。

3179

16

否

RESTORE 无法移动系统数据库。

3180

16

否

无法使用 WITH STANDBY 还原此备份,因为需要进行数据库升级。请去掉 WITH STANDBY 选项后重新发出 RESTORE 语句。

3181

10

否

还原此备份的尝试可能会遇到存储空间问题。后续消息将提供详细信息。

3182

16

否

无法还原备份集,因为在进行备份时数据库损坏。可以利用 WITH CONTINUE_AFTER_ERROR 进行补救尝试。

3183

16

否

在从该备份集进行读取时,RESTORE 检测到在数据库 "%ls" 中的页(%d:%d)上存在错误。

3184

10

否

RESTORE WITH CONTINUE_AFTER_ERROR 成功完成,但遇到了一些损坏。数据库中可能存在不一致的地方。

3185

16

否

RESTORE 无法应用此备份集,因为该数据库可疑。请还原修复了损坏数据的备份集。

3186

16

否

此备份集已损坏。RESTORE 不会尝试应用此备份集。

3187

16

否

无法指定 RESTORE WITH CHECKSUM,因为该备份集不包含校验和信息。

3188

10

否

BACKUP WITH CONTINUE_AFTER_ERROR 已用损坏的数据写入备份集。

3189

16

否

检测到该备份集损坏。

3190

16

否

无法还原文件组 '%ls',因为它在该备份集内不存在。

3191

16

否

还原操作无法继续,因为无法写入文件 '%ls'。请确保该数据库中的所有文件都可写。

3192

10

否

还原成功,但仍有延迟的事务。由于有数据不可用,无法解析这些事务。请使用 RESTORE 命令使该数据可用,或者如果您不再需要该数据,则删除这些文件组。删除文件组将导致文件组失效。

3194

16

否

页 %S_PGID 超出了该文件的结尾。只能还原在文件当前范围内的页。

3195

16

否

页 %S_PGID 无法从此备份集进行还原。RESTORE PAGE 的使用对象只能是完整备份集或将该文件添加到数据库后创建的第一个日志备份或差异备份。

3196

16

否

不支持 RESTORE master WITH SNAPSHOT。若要从快照备份还原 master,请停止该服务,并复制数据和日志文件。

3197

10

是

数据库 %ls 上的 I/O 已冻结。不需要任何用户操作。但是,如果 I/O 没有立即恢复,可以取消备份。

3198

10

是

数据库 %ls 上的 I/O 已恢复。不需要任何用户操作。

3199

16

否

RESTORE 要求 MAXTRANSFERSIZE=%u,但指定了 %u。

3201

16

否

无法打开备份设备 '%ls'。出现操作系统错误 %ls。

3202

16

否

在 "%ls" 上写入失败: %ls

3203

16

否

在 "%ls" 上读取失败: %ls

3204

16

否

备份或还原操作已中止。

3205

16

否

为备份或还原操作指定的备份设备太多;只允许指定 %d 个设备。

3206

16

否

备份设备 '%.*ls' 不存在。若要查看现有备份设备,请使用 sys.backup_devices 目录视图。若要创建新备份设备,请使用 sp_addumpdevice 或 SQL Server Management Studio。

3207

16

否

备份或还原至少需要一个备份设备。请重新运行语句并在该语句中指定备份设备。

3208

16

否

读取备份集的开始部分时遇到意外的文件结束。请确认媒体中包含有效的 SQL Server 备份集,详细信息请参阅控制台错误日志。

3209

16

否

用户实例不支持此操作。

3210

16

否

驱动器 "%ls" 中的镜像成员与驱动器 "%ls" 中的镜像成员不一致。

3211

10

否

已处理百分之 %d。

3212

16

否

镜像设备 "%ls" 和镜像设备 "%ls" 具有不同的设备。

3213

16

否

无法卸载一个或多个磁带。有关详细信息,请参阅错误日志。

3214

16

否

指定的备份镜像太多。只允许指定 %d 个备份镜像。

3215

16

否

请使用 WITH FORMAT 创建新的镜像备份集。

3216

16

否

RESTORE REWINDONLY 只适用于磁带设备。

3217

16

否

为 %ls 参数指定的值无效。

3218

16

否

备份镜像在此版本的 SQL Server 中不可用。有关不同 SQL Server 版本中功能支持的详细信息,请参阅联机丛书。

3219

16

否

不能选择文件或文件组 "%.*ls" 用于此操作。

3221

16

否

对文件 '%ls' 执行的系统函数 ReadFileEx 只读取了 %d 字节,应读取 %d 字节。

3222

16

否

对文件 '%ls' 执行的系统函数 WriteFileEx 只写入了 %d 字节,应写入 %d 字节。

3224

16

否

无法创建工作线程。

3227

16

否

"%ls" 上的备份媒体是媒体簇 %d 的一部分,该媒体簇已在 "%ls" 上进行了处理。请确保正确指定了备份设备。对于磁带设备,请确保加载了正确的卷。

3229

16

否

对设备 '%ls' 的请求已超时。

3230

16

否

在设备 '%ls' 上的操作已超过重试次数限制。

3231

16

否

在 "%ls" 上加载的媒体已格式化为支持 %d 个媒体簇,但根据指定的备份设备,应支持 %d 个媒体簇。

3232

16

否

在 "%ls" 上装入的卷没有预期的备份集标识。该卷可能因使用更新内容覆盖了此媒体簇而过时。在这种情况下,请使用媒体簇 %d 的序列号 %d 定位到正确的卷。

3234

16

否

逻辑文件 '%.*ls' 不是数据库 '%ls' 的一部分。请使用 RESTORE FILELISTONLY 来列出逻辑文件名。

3235

16

否

文件 "%.*ls" 不是数据库 "%ls" 的一部分。只能列出是此数据库的成员的文件。

3239

16

否

设备 '%ls' 上的备份集使用了 Microsoft 磁带格式的功能,但 SQL Server 不支持该功能。

3240

16

否

备份到镜像媒体集要求追加所有镜像。请提供该媒体集的所有成员,或者重新格式化一个新的媒体集。

3241

16

否

设备 '%ls' 上的媒体簇的结构不正确。SQL Server 无法处理此媒体簇。

3242

16

否

设备 '%ls' 上的文件不是有效的 Microsoft 磁带格式备份集。

3243

16

否

设备 '%ls' 上的媒体簇是用版本为 %d.%d 的 Microsoft 磁带格式创建的。SQL Server 支持的版本为 %d.%d。

3244

16

否

描述符块大小超过了 %d 字节。请使用较短的名称和/或描述字符串,然后重试该操作。

3245

16

否

无法在普通字符串和 Unicode 字符串之间转换,%ls。

3246

16

否

设备 '%ls' 上的媒体簇标记为不可追加。请用 INIT 选项重新发出该语句以覆盖该媒体。

3247

16

否

设备 '%ls' 上卷的媒体序列号(%d)错误。请取出该卷并插入卷 %d。

3249

16

否

设备 '%ls' 上的卷是备份集的延续卷。请取出该卷并插入包含备份集开始部分的卷。

3250

16

否

值 '%d' 不在 %ls 参数的取值范围内。

3251

10

否

设备 '%ls' 上的媒体簇已完成。该设备目前正由剩余簇之一重新使用。

3253

16

否

块大小参数提供的值必须是 2 的幂。

3254

16

否

设备 '%ls' 上的卷为空。

3255

16

否

设备 '%ls' 上的数据集是 SQL Server 备份集,但该备份集与此版本的 SQL Server 不兼容。

3256

16

否

设备 '%ls' 上的备份集在创建时被终止,该备份集不完整。RESTORE 序列已异常终止。

3257

16

否

磁盘卷 '%ls' 上的可用空间不足,无法创建数据库。数据库尚需 %I64u 字节的可用空间,但只有 %I64u 字节可用。

3258

16

否

设备 "%ls" 上的卷不是当前正处理的媒体集的一部分。请确保使用正确的媒体加载了备份设备。

3260

16

否

内部缓冲区已满。

3261

16

否

SQL Server 无法使用虚拟设备配置。

3262

10

否

文件 %d 上的备份集有效。

3263

16

否

无法将设备 '%ls' 上的卷用作延续卷。其序列号为 %d,属于当前媒体集的媒体簇 %d。请插入新卷,或插入序列号为 %d、属于当前媒体集的媒体簇 %d 的卷。

3264

16

否

该操作尚未进行到允许 RESTART 的程度。请去掉 RESTART 限定符后重新发出该语句。

3265

16

否

该登录名没有足够的权限。需要有 sysadmin 角色的成员资格才能将 VIRTUAL_DEVICE 用于 BACKUP 或 RESTORE。

3266

16

是

在 "%ls" 结尾处的备份数据格式不正确。该媒体上的备份集可能已损坏,无法使用。若要确定该媒体上的备份集,请使用 RESTORE HEADERONLY。若要确定备份集的可用性,请运行 RESTORE VERIFYONLY。如果所有备份集都不完整,请使用 BACKUP WITH FORMAT 重新格式化该媒体,此操作将破坏所有备份集。

3267

16

否

资源不足,无法创建 UMS 调度程序。

3268

16

否

无法使用备份文件 '%ls',因为原先格式化该文件时所用扇区大小为 %d,而目前所在设备的扇区大小为 %d。

3269

16

否

无法还原文件 '%ls',因为原先写入该文件时所用扇区大小为 %d,而 '%ls' 目前所在设备的扇区大小为 %d。

3270

16

否

发生内部一致性错误。此错误与断定类似。请与技术支持联系以获取帮助。

3271

16

否

在文件 "%ls:" 上发生不可恢复的 I/O 错误: %ls。

3272

16

否

'%ls' 设备的硬件扇区大小为 %d,但块大小参数却指定了不兼容的替代值 %d。请用兼容的块大小重新发出该语句。

3276

16

否

只有在创建备份集时使用了 WITH SNAPSHOT 的情况下,才能使用 WITH SNAPSHOT。

3277

16

否

WITH SNAPSHOT 必须仅用于一个虚拟设备。

3278

16

否

无法加密字符串 %ls

3279

16

否

由于密码错误,访问遭拒绝

3280

16

否

不支持在裸设备上进行备份,而 '%ls' 是裸设备。

3281

10

否

在 '%ls' 上释放并启动了重绕。

3283

16

否

文件 "%ls" 无法正确初始化。有关详细信息,请检查错误日志。

3284

16

否

设备 '%ls' 上的文件标记未对齐。使用用于创建备份集的相同块大小重新发布 Restore 语句: '%d' 看起来像一个可能值。

3301

21

是

事务日志包含无效的记录(logop %d)。该日志已损坏。请利用完整备份还原数据库,或者修复该数据库。

3302

21

是

在数据库 '%.*ls' 中重做日志记录操作时,无法到达日志记录 ID 为 %S_LSN 的日志结尾。这表示 ID 为 %S_LSN 的日志记录有数据损坏。请利用完整备份还原数据库,或者修复该数据库。

3313

21

是

在重做数据库 '%.*ls' 的日志中记录的操作时,日志记录 ID %S_LSN 出错。通常,特定故障以前会在 Windows 事件日志服务中记录为错误。请利用完整备份还原数据库,或者修复该数据库。

3314

21

是

在数据库 '%.*ls' 中撤消日志记录下的操作时,在日志记录 %S_LSN 处出错。通常,这一特定故障以前在 Windows 事件日志服务中会记录为错误。请利用备份还原数据库或文件,或者修复该数据库。

3315

21

是

在回滚过程中,以下进程未持有预期的锁: 进程 %d,该进程的模式为 %d,级别为 %d,位于数据库 '%.*ls' 的第 %S_RID 行上,并在事务 %S_XID 之下。请还原该数据库的备份,或者修复该数据库。

3316

21

是

在数据库 '%.*ls' 中撤消日志记录下的操作时,在日志记录 ID %S_LSN 处出错。找不到该行。请利用完整备份还原数据库,或者修复该数据库。

3401

10

是

回滚事务时,恢复期间出错。事务已延迟。请还原错误的页或文件,然后重新运行恢复操作。

3402

10

是

数据库 '%ls' 标记为 %ls,处于不允许运行恢复的状态。

3403

10

是

由于指定了跟踪标志 3608,仅恢复 master 数据库。这只是一条信息性消息,不需要用户执行任何操作。

3404

10

是

启动时无法检查新系统或重命名的服务器。此检查的逻辑意外失败。请重新运行安装程序,或修复有问题的注册表项。

3406

10

是

已前滚了数据库 '%.*ls' (%d)中的 %d 个事务。这只是一条信息性消息,不需要用户执行任何操作。

3407

10

是

已回滚了数据库 '%.*ls' (%d)中的 %d 个事务。这只是一条信息性消息,不需要用户执行任何操作。

3408

10

是

恢复完毕。这只是一条信息性消息,不需要用户执行任何操作。

3409

16

是

性能计数器共享内存设置失败,错误为 %d。请为此实例重新安装 sqlctr.ini,并确保实例登录帐户具有正确的注册表权限。

3410

10

是

文件组 %s 中的数据为脱机数据,并且存在延迟的事务。请使用 RESTORE 恢复该文件组。如果不想恢复该文件组,请删除它。只有在解决此问题后,才能截断日志。

3411

21

是

配置块版本 %d 不是有效的版本号。SQL Server 正在退出。请还原 master 数据库,或者重新安装。

3412

10

是

警告: 服务器实例是用最小配置启动选项(-f)启动的。用最小配置启动 SQL Server 实例会自动将服务器置于单用户模式。用最小配置启动服务器后,应更改相应的服务器选项值,然后停止并重新启动服务器。

3413

21

是

数据库 ID 为 %d。无法将数据库标记为可疑。对 sys.databases.database_id 进行的 Getnext NC 扫描失败。请参阅错误日志中以前的错误,以标识原因并更正任何相关的问题。

3414

10

是

恢复期间出错,导致数据库 '%.*ls' (数据库 ID %d)无法重新启动。请诊断并纠正这些恢复错误,或者从已知的正确备份中还原。如果无法更正错误,或者为意外错误,请与技术支持人员联系。

3415

16

是

无法升级数据库 '%.*ls',因为它是只读的,或者具有只读文件。请将数据库或文件设为可写,然后重新运行恢复操作。

3416

16

是

服务器包含只读文件,必须将这些文件改为可写文件,才能重新设置服务器的排序规则。

3417

21

是

无法恢复 master 数据库。SQL Server 无法运行。请利用完整备份还原 master 数据库,修复它,或者重新生成它。有关如何重新生成 master 数据库的详细信息,请参阅 SQL Server 联机丛书。

3418

10

是

恢复操作无法延迟错误 %d。只有在使用完整恢复模式和活动的备份日志链的数据库中,才能延迟错误。

3419

16

是

正在跳过对数据库 '%.*ls' 的恢复,因为它需要升级内容,但它已标记为备用。使用 RESTORE DATABASE WITH NORECOVERY 使数据库返回到还原状态,然后继续还原顺序。

3420

21

是

数据库快照 '%ls' 导致某一 IO 操作失败并被标记为可疑。必须将其删除,然后重新创建它。

3421

10

是

已在 %I64d 秒内完成对数据库 %ls (数据库 ID %d)的恢复(分析 %I64d 毫秒,重做 %I64d 毫秒,撤消 %I64d 毫秒)。这只是一条信息性消息。用户不需要执行任何操作。

3422

10

是

由于在例程 '%hs' 中发生错误 %d,数据库 %ls 已关闭。在与该数据库的所有连接都中止后,将尝试重新启动非快照数据库。

3429

10

是

恢复操作无法确定名为 '%.*ls' 的跨数据库事务 %S_XID 的结果,该事务位于数据库 '%.*ls' (数据库 ID %d)中。协调数据库(数据库 ID %d)不可用。假定该事务已提交。如果该事务尚未提交,可以在协调数据库可用时重试恢复操作。

3431

21

是

无法恢复数据库 '%.*ls' (数据库 ID 为 %d),因为事务结果尚未解析。Microsoft 分布式事务处理协调器 (MS DTC) 事务已准备好,但 MS DTC 无法确定解析方法。若要进行解析,请修复 MS DTC,从完整备份进行还原,或者修复数据库。

3434

20

是

无法更改排序顺序或区域设置。在尝试将服务器按照新的排序规则重新建立索引时出错。SQL Server 正在关闭。重新启动 SQL Server 以继续操作且保持排序顺序不变。诊断并更正以前的错误,然后重试该操作。

3437

21

是

在恢复数据库 '%.*ls' 时出错。无法连接到 Microsoft 分布式事务处理协调器(MS DTC)以检查事务 %S_XID 的完成状态。请修复 MS DTC,然后再次运行恢复操作。

3441

21

是

在启动备用数据库 '%.*ls' (数据库 ID 为 %d)的过程中,RESTORE 语句无法访问它的备用文件('%ls')。操作系统错误为 '%ls'。诊断该操作系统错误,并更正此问题,然后重试启动操作。

3442

21

是

恢复备用数据库 '%.*ls' (数据库 ID 为 %d)失败。撤消文件中空间不足。请增大撤消文件的大小,然后重试恢复操作。

3443

21

是

数据库 '%.*ls' (数据库 ID 为 %d)标记为备用或只读,但已被修改。无法执行 RESTORE LOG 语句。请从备份还原数据库。

3445

21

是

文件 '%ls' 不是数据库 '%.*ls (数据库 ID 为 %d)的有效撤消文件。请检查文件路径,并指定正确的文件。

3446

16

否

数据库 '%.*ls' 的主日志文件不可用。无法备份日志。

3447

16

否

无法激活或扫描数据库 '%.*ls' 的所有日志文件。

3448

21

是

回滚时遇到了一页,该页的日志序列号(LSN)小于原来的日志记录 LSN。对于事务 ID %S_XID,无法在数据库 '%.*ls' (数据库 ID 为 %d)的页 %S_PGID 上撤消日志记录 %S_LSN。页信息: LSN = %S_LSN,类型 = %ld。日志信息: 操作码 = %ld,上下文 %ld。请还原或修复该数据库。

3449

21

是

SQL Server 必须关闭,才能恢复数据库(数据库 ID 为 %d)。该数据库是无法关闭的用户数据库,或者是系统数据库。请重新启动 SQL Server。如果再次启动后仍无法恢复该数据库,则修复或还原它。

3450

10

是

数据库 '%.*ls' (%d)的恢复已完成 %d%% (剩余时间约为 %d 秒)。目前处于第 %d 阶段,共 3 阶段。这只是一条信息性消息,不需要用户执行任何操作。

3452

10

是

数据库 '%.*ls' (%d)的恢复操作检测到表 ID %d 中的标识值可能不一致。请运行 DBCC CHECKIDENT ('%.*ls')。

3453

16

否

此版本无法重做任何由 SQL Server 7.0 执行的索引创建操作或日志未记录的操作。不可能进行进一步的前滚。

3454

10

是

恢复操作正在数据库 '%.*ls' (%d)中写入检查点。这只是一条信息性消息,不需要用户执行任何操作。

3456

21

是

对于事务 ID %S_XID,无法在数据库 '%.*ls' (数据库 ID 为 %d)的页 %S_PGID 上重做日志记录 %S_LSN。页: LSN = %S_LSN,类型 = %ld。日志: 操作码 = %ld,上下文 %ld,上一页的 LSN: %S_LSN。请从数据库备份还原该数据库,或者修复它。

3457

21

是

事务性文件系统资源管理器 '%.*ls' 无法恢复。有关详细信息,请参阅伴随的错误消息,可利用该消息确定适当的用户操作。

3458

16

否

由于出现错误,恢复操作无法在数据库 "%.*ls" 中扫描已删除的分配单元。无法清除这些分配单元。

3505

14

否

只有数据库 "%.*ls" 的所有者或具有相关权限的人才能运行 CHECKPOINT 语句。

3604

10

否

已忽略重复的键。

3606

10

否

发生算术溢出。

3607

10

否

发生以零作除数错误。

3608

16

否

无法为令牌分配 GUID。

3609

16

否

事务在触发器中结束。批处理已中止。

3612

10

否

%hs SQL Server 执行时间:%hs CPU 时间 = %lu 毫秒,占用时间 = %lu 毫秒。

3613

10

否

SQL Server 分析和编译时间: %hs CPU 时间 = %lu 毫秒,占用时间 = %lu 毫秒。

3615

10

否

表 '%.*ls'。扫描计数 %d,逻辑读取 %d 次,物理读取 %d 次,预读 %d 次,lob 逻辑读取 %d 次,lob 物理读取 %d 次,lob 预读 %d 次。

3616

16

否

在触发器执行过程中引发了错误。批处理已中止,用户事务(如果有)已回滚。

3619

10

是

由于日志空间用尽,无法在数据库 ID %d 中写入检查点记录。请与数据库管理员联系,截断日志或为数据库日志文件分配更多空间。

3620

10

是

由于日志空间用尽,在数据库 '%.*ls' 中禁用了检查点的自动执行。当数据库所有者成功执行了数据库的检查点操作后,将启用检查点的自动执行。请与数据库所有者联系,截断日志文件或为日志增加更多的磁盘空间,然后重试 CHECKPOINT 语句。

3621

10

否

语句已终止。

3622

10

否

警告: 发生了无效的浮点运算。

3623

16

否

出现无效的浮点操作。

3624

20

是

系统断定检查已失败。有关详细信息,请查看 SQL Server 错误日志。通常,断定失败是由软件 bug 或数据损坏导致的。若要检查数据库是否已损坏,请考虑运行 DBCC CHECKDB。如果您同意在安装过程中将转储发送到 Microsoft,则将向 Microsoft 发送微型转储。更新可能在 Microsoft 的最新 Service Pack 或技术支持部门的 QFE 中提供。

3625

20

是

尚未实现 '%hs'。

3627

17

是

由于此时执行的并行操作太多,无法启动新的并行操作。请使用"最大工作线程数"配置选项增大允许的线程数,或者减少系统上运行的并行操作的数目。

3628

24

是

在处理用户请求的过程中,数据库引擎从操作系统收到浮点异常。请重试该事务。如果问题仍然存在,请与系统管理员联系。

3633

16

是

在对 '%hs'(%d)处的 '%ls' 尝试 '%ls' 时,操作系统返回了错误 '%ls'。

3634

16

是

在对 '%ls' 尝试 '%ls' 时,操作系统返回了错误 '%ls'。

3635

16

是

在处理 '%ls' 元数据(数据库 ID %d,文件 ID %d 和事务='%.*ls')时出错。其他上下文='%ls'。位置='%hs'(%d)。请重试该操作;如果问题仍然存在,请与数据库管理员联系以检查锁定和内存配置。请检查应用程序,查看是否有可能的死锁冲突。

3636

16

否

在处理 '%ls' 元数据(数据库 ID %d,文件 ID %d)时出错。

3637

16

否

无法从 DAC 连接启动并行操作。

3638

10

否

SQL 文本缓存内存使用量: %d 页。这只是一条信息性消息,不需要用户执行任何操作。

3701

11

否

无法对 %S_MSG '%.*ls' 执行 %S_MSG,因为它不存在,或者您没有所需的权限。

3702

16

否

无法删除数据库 "%.*ls",因为该数据库当前正在使用。

3703

16

否

无法分离 %S_MSG '%.*ls',因为它当前正在使用。

3705

16

否

无法将 DROP %ls 用于 '%.*ls',因为 '%.*ls' 是 %S_MSG。使用 %ls。

3706

16

否

不能对数据库快照执行 %S_MSG。

3707

16

否

不能分离可疑或恢复挂起数据库。必须修复或删除它。

3708

16

否

无法对 %S_MSG '%.*ls' 执行 %S_MSG,因为它是系统 %S_MSG。

3709

16

否

当数据库快照 "%.*ls" 引用该数据库时,无法对该数据库执行 %S_MSG。请首先删除该数据库。

3710

16

否

当服务器处于最低配置模式时,无法分离已打开的数据库。

3716

16

否

无法删除 %S_MSG '%.*ls',因为它已绑定到一个或多个 %S_MSG。

3717

16

否

无法使用 DROP DEFAULT 语句删除默认约束。请使用 ALTER TABLE 删除默认约束。

3721

16

否

无法重命名类型 '%.*ls',因为对象 '%.*ls' 正在引用它。

3723

16

否

不允许对索引 '%.*ls' 显式地使用 DROP INDEX。该索引正用于 %ls 约束的强制执行。

3724

16

否

无法对 %S_MSG '%.*ls' 执行 %S_MSG,因为它正用于复制。

3725

16

否

约束 '%.*ls' 正由表 '%.*ls' 的外键约束 '%.*ls' 引用。

3726

16

否

无法删除对象 '%.*ls',因为该对象正由一个 FOREIGN KEY 约束引用。

3727

10

否

未能删除约束。请参阅前面的错误信息。

3728

16

否

'%.*ls' 不是约束。

3729

16

否

无法对 '%.*ls' 执行 %ls,因为对象 '%.*ls' 正引用它。

3730

16

否

当默认约束 '%.*ls' 正由外键用作 SET DEFAULT 引用操作时,无法删除该约束。

3732

16

否

无法删除类型 '%.*ls',因为它正由对象 '%.*ls' 引用。可能还有其他对象在引用此类型。

3733

16

否

约束 '%.*ls' 不属于表 '%.*ls'。

3734

16

否

无法删除主键约束 '%.*ls',因为该表具有 XML 索引或空间索引。

3735

16

否

因为对表 '%.*ls' 启用了更改跟踪,所以无法删除该表的主键约束 '%.*ls'。更改跟踪需要该表的主键约束。只有禁用更改跟踪,才能删除该约束。

3737

16

否

无法删除文件 '%ls'。有关详细信息,请参阅 SQL Server 错误日志。

3738

10

否

正在删除数据库文件 '%ls'。

3739

11

否

无法对索引 '%.*ls' 执行 %ls,因为该索引不是统计信息集合。

3740

16

否

无法删除 %S_MSG '%.*ls',因为表中至少有一部分内容驻留在只读文件组内。

3741

16

否

无法删除 %S_MSG '%.*ls',因为表中至少有一部分内容驻留在脱机文件组内。

3743

16

否

已为数据库镜像启用数据库 '%.*ls',必须删除数据库镜像才能删除该数据库。

3744

16

否

在联机删除索引的语句中,只允许使用一个子句。

3745

16

否

只能联机删除一个聚集索引。

3746

16

否

不能删除视图 '%.*ls' 的聚集索引,因为该视图正用于复制。

3747

16

否

不能使用删除聚集索引子句来删除对视图创建的聚集索引。聚集索引 '%.*ls' 是对视图 '%.*ls' 创建的。

3748

16

否

不能使用删除聚集索引子句来删除非聚集索引 '%.*ls'。

3749

16

否

不能使用旧的 'Table.Index' 语法删除 XML 索引 '%.*ls',请改用 'Index ON Table' 语法。

3750

10

否

警告: 由于禁用了 %S_MSG 的聚集索引,%S_MSG '%.*ls' 的索引 '%.*ls' 已禁用。

3751

16

否

不能将 SP_DROPEXTENDEDPROC 或 DBCC DROPEXTENDEDPROC 与 '%.*ls' 一起使用,因为 '%.*ls' 是 %S_MSG。使用 %ls。

3801

10

否

警告: "%.*ls"."%.*ls" 的索引 "%.*ls" 可能受到排序规则升级的影响。请运行 DBCC CHECKTABLE。

3802

10

否

警告: "%.*ls"."%.*ls" 的约束 "%.*ls" 可能受到排序规则升级的影响。请禁用 WITH CHECK 后再启用它。

3803

10

否

警告: "%.*ls"."%.*ls" 的索引 "%.*ls" 已禁用,因为校验和函数的实现已更改。

3804

10

否

警告: 表 "%.*ls"."%.*ls" 的检查约束 "%.*ls" 已禁用,因为校验和函数的实现已更改。

3805

10

否

警告: 表 "%.*ls"."%.*ls" 的索引 "%.*ls" 可能已损坏,因为它引用计算列 "%.*ls",而该列包含的从字符串到日期的转换具有不确定性。请运行 DBCC CHECKTABLE 验证索引。请考虑使用具有确定日期格式(例如 121)的显式 CONVERT。在 90 兼容模式下无法创建引用不确定表达式的计算列索引。有关详细信息,请参阅联机丛书主题 "对计算列创建索引"。

3806

10

否

警告: 索引视图 "%.*ls"."%.*ls" 可能已损坏,因为它包含的从字符串到日期的转换具有不确定性。请运行 DBCC CHECKTABLE 验证视图。请考虑使用具有确定日期格式(例如 121)的显式 CONVERT。在 90 兼容模式下无法创建引用不确定表达式的索引视图。有关详细信息,请参阅联机丛书主题'创建索引视图'。

3807

17

否

创建操作失败,因为所有可用的标识符都已用完。

3808

10

否

警告: "%.*ls"."%.*ls" 的索引 "%.*ls" 已禁用,因为该索引是使用 ignore_dup_key 索引选项对视图定义的。请删除该索引,如果可能,在不使用 ignore_dup_key 选项的情况下重新创建它。您可能需要更改视图的逻辑结构,以确保所有的行都是唯一的。

3809

16

否

数据库 "%.*ls" 的升级失败,因为对象 ID %d 的索引 "%.*ls" 的名称与同一表中的另一索引重名。

3810

10

否

程序集的事件通知 "%.*ls" 已被删除。

3811

10

否

服务队列的事件通知 "%.*ls" 已被删除,因为未指定 broker 实例。

3812

10

否

对象的事件通知 "%.*ls" 已被删除。

3813

16

否

升级登录名 '%.*ls' 失败,因为其名称或 SID 与其他登录名或服务器角色重复。

3814

16

否

映射到服务器 '%.*ls' 远程登录名 '%.*ls' 上的本地登录名无效。请在升级前删除并重新创建远程登录名。

3815

16

否

映射到服务器 '%.*ls' 链接登录名 '%.*ls' 上的本地登录名无效。请在升级前删除并重新创建链接登录名。

3816

16

否

升级登录名 '%.*ls' 失败,因为其密码哈希无效。请在升级之前更新登录密码。

3817

10

否

警告: "%.*ls"."%.*ls" 的索引 "%.*ls" 已禁用,因为几何图形和地理方法的实现已更改。

3818

16

否

因为具有 6 个字节的 CUID 列的行长度超过允许的 %d 个字节的最大长度,所以无法将该列添加到对象 %.*ls 的索引 "%.*ls" 中。

3819

10

否

警告: "%.*ls"."%.*ls" 的检查约束 "%.*ls" 已禁用并且设置为不受信任,因为几何图形和地理方法的实现已更改。

3820

10

否

警告: 已将 6 字节的 CUID 列添加到对象 %.*ls 的索引 "%.*ls" 中,但其最大行大小超出了允许的最大大小 %d 字节。对于某些大值组合,对此索引执行 INSERT 或 UPDATE 操作将会失败。

3821

10

否

警告: "%.*ls"."%.*ls" 的外键约束 "%.*ls" 已禁用,因为几何图形和地理方法的实现已更改。

3822

10

否

警告: 堆 "%.*ls"."%.*ls" 已经对依赖几何图形或地理方法而且可能包含过期信息的计算列进行持久化。因此,DBCC 可能报告此表存在不一致。应当取消对依赖几何图形或地理方法的持久化计算列的持久化,然后再次对其进行持久化以刷新数据。

3823

10

否

警告: 对象 "%.*ls"."%.*ls" 无法绑定,已在升级过程中忽略。请考虑检查和更正其定义。

3851

10

否

在系统表 sys.%ls%ls 中发现无效的行(%ls)。

3852

10

否

sys.%ls%ls 中的行(%ls)在 sys.%ls%ls 中没有匹配的行(%ls)。

3853

10

否

sys.%ls%ls 中的行(%ls)的属性(%ls)在 sys.%ls%ls 中没有匹配的行(%ls)。

3854

10

否

sys.%ls%ls 中的行(%ls)的属性(%ls)与 sys.%ls%ls 中的行(%ls)匹配,但该行无效。

3855

10

否

属性(%ls)存在,但 sys.%ls%ls 中没有行(%ls)。

3856

10

否

属性(%ls)存在,但它与 sys.%ls%ls 中的行(%ls)不匹配。

3857

10

否

缺少 sys.%ls%ls 中的行(%ls)所需的属性(%ls)。

3858

10

否

sys.%ls%ls 中的行(%ls)的属性(%ls)具有无效的值。

3859

10

否

警告: 数据库 ID %d 中的系统目录已直接更新,最近的更新时间为 %S_DATE。

3860

10

否

无法升级数据库 ID 32767。此 ID 值保留供 SQL Server 内部使用。

3862

10

否

CLR 类型 '%.*ls'.'%.*ls' 已禁用,因为此 CLR 类型的磁盘格式已更改。请使用 DROP TYPE 删除此禁用的类型。

3864

23

是

在 ID 为 %d 的数据库中找不到 ID 为 %d 的对象的索引(ID 为 %d)条目。架构可能已损坏。请运行 DBCC CHECKDB。

3901

16

否

当事务与标记选项一起使用时,必须指定事务名。

3902

16

否

COMMIT TRANSACTION 请求没有对应的 BEGIN TRANSACTION。

3903

16

否

ROLLBACK TRANSACTION 请求没有对应的 BEGIN TRANSACTION。

3904

21

否

无法撤消逻辑页 %S_PGID 的拆分,该逻辑页位于对象 '%.*ls'、数据库 '%.*ls' 中。拆分所得两页所包含的数据总和多于一页所能容纳的数据。

3906

16

否

无法更新数据库 "%.*ls",因为数据库是只读的。

3908

16

否

无法在数据库 '%.*ls' 中运行 BEGIN TRANSACTION,因为该数据库处于回避恢复模式

3909

16

否

会话绑定令牌无效。

3910

16

否

其他会话正在使用事务的上下文。

3912

16

否

当服务器未处于 XP 调用中时,无法用 XP 令牌进行绑定。

3913

16

是

TDS 重置连接协议错误。客户端驱动程序同时请求了 ResetConnectionKeepLocalXact 和 ResetConnectionKeepDTCXact。服务器中不应发生这种情况。

3914

16

否

数据类型 "%s" 对于事务名称或保存点名称无效。允许使用的数据类型为 char、varchar、nchar、varchar(max)、nvarchar 和 nvarchar(max)。

3915

16

否

不能在 INSERT-EXEC 语句内部使用 ROLLBACK 语句。

3916

16

否

不能在 INSERT-EXEC 语句内部使用 COMMIT 语句,除非首先使用了 BEGIN TRANSACTION。

3917

16

否

会话绑定到了正在使用的事务上下文。已忽略批处理中的其他语句。

3918

16

否

语句或函数必须在用户事务上下文中执行。

3919

16

否

无法登记事务,因为该事务已提交或回滚。

3920

10

否

WITH MARK 选项仅应用于第一个 BEGIN TRAN WITH MARK 语句。已忽略该选项。

3921

16

否

如果没有活动事务,就无法得到事务令牌。请在启动事务后重新发出该语句

3922

16

否

无法登记事务,因为该事务不存在。

3923

10

否

无法对数据库 '%.*ls' 使用事务标记,该数据库有未备份的大容量日志记录操作。已忽略该标记。

3924

10

否

试图绑定到新事务时,会话登记到活动用户事务。该会话已脱离前面的用户事务。

3925

16

否

无效的事务标记名。已保留 'LSN:' 前缀。

3926

10

否

此会话中的活动事务已由另外一个会话提交或终止。

3927

10

否

此会话已有活动事务,但仍试图登记分布式事务处理协调器事务。

3928

16

否

标记的事务 "%.*ls" 失败。尝试通过提交标记的事务将标记放入日志时发生了超时。这可能是由于与已准备好但是未提交或已中止的 Microsoft 分布式事务处理协调器(MS DTC)事务或其他本地已标记事务发生争用而导致的。请再次尝试该操作,如果该错误仍然存在,请确定发生争用的原因。

3929

16

否

在单用户数据库中不允许分布式或绑定的事务。

3930

16

否

当前事务无法提交,而且无法支持写入日志文件的操作。请回滚该事务。

3931

16

否

当前事务无法提交,而且无法回滚到保存点。请回滚整个事务。

3932

16

否

所提供的保存点名 "%.*ls" 太长。允许的最大长度为 %d 个字符。

3933

16

否

无法将此事务提升为分布式事务,因为在此事务中有活动的保存点。

3934

14

否

当前用户不能使用此 FILESTREAM 事务上下文。若要获取有效的 FILESTREAM 事务上下文,请使用 GET_FILESTREAM_TRANSACTION_CONTEXT。

3935

16

否

无法初始化 FILESTREAM 事务上下文。这可能是由于资源不足导致的。重试该操作。错误代码: 0x%x。

3936

16

否

在试图将 FILESTREAM 数据刷新到磁盘时出错,所以无法提交该事务。提交文件时,文件可能处于打开状态,或者发生了磁盘 I/O 错误。'%.*ls' 是受影响的文件之一。错误代码: 0x%x

3937

16

否

在回滚事务的过程中,当试图将回滚通知传递给 FILESTREAM 筛选器驱动程序时出错。错误代码: 0x%0x。

3938

18

否

由于该事务与使用同一事务的 FILESTREAM 关闭操作的执行冲突,该事务已停止。该事务将回滚。

3939

16

否

在批处理开始时检测到不可提交的事务。该事务已回滚。这是由于处理此事务上下文中的 FILESTREAM 请求时发生了错误。

3950

16

否

在尝试读取下一行时,版本存储扫描超时。请稍后在系统不忙时重试该语句。

3951

16

否

数据库 '%.*ls' 中的事务失败,因为该语句是在快照隔离级别下运行的,但该事务不是在快照隔离级别下启动的。您在事务启动后不能将事务的隔离级别更改为快照,除非该事务最初是在快照隔离级别下启动的。

3952

16

否

快照隔离事务访问数据库 '%.*ls' 失败,因为在此数据库中不允许快照隔离。请使用 ALTER DATABASE 以允许快照隔离。

3953

16

否

数据库 '%.*ls' 中的快照隔离事务失败,因为在启动当前事务时该数据库未恢复。请在恢复数据库后重试该事务。

3954

16

否

快照隔离事务未能在数据库 '%.*ls' 中启动,因为不允许快照隔离的 ALTER DATABASE 命令已在该事务启动前执行。数据库正在转换到 OFF 状态。您需要更改事务的隔离级别,或者在数据库中重新启用快照隔离。

3955

16

否

数据库 '%.*ls' 中的快照隔离事务失败,因为为此数据库跳过了恢复操作。您必须首先恢复数据库,然后才能在快照隔离级别下运行事务。

3956

16

否

快照隔离事务未能在数据库 '%.*ls' 中启动,因为用于启用此数据库的快照隔离的 ALTER DATABASE 命令尚未完成。数据库正在转换到挂起 ON 状态。您必须等待,直到 ALTER DATABASE 命令成功完成。

3957

16

否

数据库 '%.*ls' 中的快照隔离事务失败,因为在当前事务启动时该数据库不允许使用快照隔离。重试该事务可能有用。

3958

16

否

在访问数据库 '%.*ls' 的表 '%.*ls' 中的版本控制行时事务中止。找不到请求的版本控制行。您的 tempdb 可能空间不足。有关如何配置 tempdb 以进行版本控制的说明,请参阅联机丛书。

3959

10

是

版本存储区已满。不能添加新的版本。需要访问该版本存储区的事务可能被回滚。有关如何配置 tempdb 以进行版本控制的说明,请参阅联机丛书。

3960

16

否

快照隔离事务由于更新冲突而中止。您无法在数据库 '%.*ls' 中使用快照隔离来直接或间接访问表 '%.*ls',以便更新、删除或插入已由其他事务修改或删除的行。请重试该事务或更改 update/delete 语句的隔离级别。

3961

16

否

数据库 '%.*ls' 中的快照隔离事务失败,因为自此事务启动后,该语句所访问的对象已由其他并发事务中的 DDL 语句修改。这是不允许的,因为未对元数据进行版本控制。如果与快照隔离混合,对元数据的并发更新可能导致不一致。

3962

16

否

不支持在执行 SQL Server 内部查询期间绑定到另一事务。请检查您的登录触发器定义,并删除使用的任何 sp_bindsession (如果有)。如果在登录触发器执行期间未出现此错误,请与生产支持团队联系。

3963

16

否

数据库 '%.*ls' 中的事务失败,因为在快照隔离级别下不支持分布式事务。

3964

16

否

事务失败,因为在快照隔离事务内不允许此 DDL 语句。由于未对元数据进行版本控制,如果与快照隔离混合,元数据更改可能导致不一致。

3965

16

否

PROMOTE TRANSACTION 请求失败,因为没有活动的本地事务。

3966

17

否

在访问版本存储区时事务被回滚。在版本存储区由于 tempdb 中空间不足而收缩时,事务被提前标记为牺牲品。之所以该事务被提前标记为牺牲品,是因为它可能需要那些为了在 tempdb 中释放一些空间而已被删除的行版本。请重试该事务

3967

17

是

tempdb 中的空间不足以保存行版本。需要收缩版本存储区以在 tempdb 中释放一些空间。事务(id=%I64d xsn=%I64d spid=%d elapsed_time=%d)已被标记为牺牲品,并且如果访问版本存储区则该事务将被回滚。如果问题仍然存在,则可能是因为 tempdb 的大小不合适或运行事务的时间太长。有关如何配置 tempdb 以进行版本控制的说明,请参阅联机丛书。

3968

10

否

数据库 '%.*ls' 中无快照隔离或读提交的快照,因为启动 SQL Server 时采用了一个或多个未记录的跟踪标志,而这些标志使得用户无法对数据库启用版本控制功能。使用快照隔离启动的事务将失败,并且在读提交快照下运行的查询将成功,但仍将依靠基于锁定的读提交。

3969

16

否

在运行 SQL Server 内部查询期间不支持分布式事务。请检查您的登录触发器定义,并删除使用的任何分布式事务(如果有)。如果在登录触发器执行期间未出现此错误,请与生产支持团队联系。

3970

16

否

此操作与此事务上的另一个挂起操作冲突。此操作失败。

3971

16

否

服务器无法继续执行该事务。说明: %I64x。

3972

20

是

传入的表格格式数据流(TDS)协议不正确。事务管理器事件的长度错误。事件类型: %d。长度应为: %d。实际长度: %d。

3973

16

否

该数据库当前正由同一工作区中的另一个线程以排他模式使用。该操作失败。

3974

16

否

在工作区中以排他模式使用的数据库的数目受限制。由于超过了此限制,该操作失败。

3975

16

否

sp_getbindtoken 不支持 varchar(max) 数据类型。批处理已中止。

3976

16

否

该事务名具有奇数长度 %d。批处理已中止。

3977

16

否

保存点名称不能为 NULL。批处理已中止。

3978

16

否

不允许在回滚到保存点之后开始新事务。

3979

16

否

TM 请求的长度比预期的长。未处理该请求。

3980

16

否

无法运行请求,因为批处理已中止。这可能是由于从客户端发送的中止信号导致的;或者其他请求正在同一会话中运行,这会使会话处于忙状态。

3981

16

否

无法执行该事务操作,因为有挂起请求正在此事务上运行。

3982

16

否

当 DTC 或绑定的事务活动时,不允许启动新事务。

3983

16

否

该操作失败,因为会话不是单线程。

3984

16

否

在事务更改期间无法获取数据库锁。

3985

16

否

在更改事务上下文时出错。这通常是由于系统中内存不足。请尝试释放更多内存。

3986

19

否

事务时间戳已用完。重新启动服务器。

3987

10

否

此数据库中总是启用 SNAPSHOT ISOLATION。

3988

16

否

不允许启动新事务,因为有其他线程正在该会话中运行。

3989

16

否

不允许启动新请求,因为该请求应具有有效的事务描述符。

3990

16

否

不允许在用户定义的例程、触发器或聚合内提交事务,因为事务不是在该 CLR 级别内启动的。请更改应用程序逻辑以强制实施严格的事务嵌套。

3991

16

否

在进入用户定义的例程、触发器或聚合 "%.*ls" 前处于活动状态的上下文事务在其中已终止,这是不允许的。请更改应用程序逻辑以强制实施严格的事务嵌套。

3992

16

否

在用户定义的例程、触发器或聚合 "%.*ls" 内事务计数已从 %d 更改为 %d。这是不允许的,并且用户事务将被回滚。请更改应用程序逻辑以强制实施严格的事务嵌套。

3993

16

否

已在用户定义的例程、触发器或聚合 "%.*ls" 中启动的用户事务在从中退出时未结束。这是不允许的,并且用户事务将被回滚。请更改应用程序逻辑以强制实施严格的事务嵌套。

3994

16

否

用户定义的例程、触发器或聚合尝试回滚不是在该 CLR 级别启动的事务。将引发一个异常,以防止执行用户定义的其余例程、触发器或聚合。

3995

16

否

未知的事务隔离级别 %d,有效值的范围是 0 到 5。

3996

16

否

分布式事务不支持快照隔离级别。请使用其他隔离级别或不使用分布式事务。

3997

16

否

在 MARS 批处理中启动的某个事务在该批处理结束时仍处于活动状态。该事务将回滚。

3998

16

否

在批处理结束时检测到不可提交的事务。该事务将回滚。

3999

17

是

由于错误 %d,无法将该提交表刷新到 DBID %d 中的磁盘。有关详细信息,请查看错误日志