当前位置: 代码迷 >> 综合 >> 插入排序 Insertion Sort Aizu - ALDS1_1_A
  详细解决方案

插入排序 Insertion Sort Aizu - ALDS1_1_A

热度:25   发布时间:2023-12-12 14:21:26.0

题目:

Write a program of the Insertion Sort algorithm which sorts a sequence A in ascending order. The algorithm should be based on the following pseudocode:

for i = 1 to A.length-1key = A[i]/* insert A[i] into the sorted sequence A[0,...,j-1] */j = i - 1while j >= 0 and A[j] > keyA[j+1] = A[j]j--A[j+1] = key

Note that, indices for array elements are based on 0-origin.

To illustrate the algorithms, your program should trace intermediate result for each step.

Input

The first line of the input includes an integer N, the number of elements in the sequence.

In the second line, N elements of the sequence are given separated by a single space.

Output

The output consists of N lines. Please output the intermediate sequence in a line for each step. Elements of the sequence should be separated by single space.

Constraints

1 ≤ N ≤ 100

Sample Input 1

6
5 2 4 6 1 3

Sample Output 1

5 2 4 6 1 3
2 5 4 6 1 3
2 4 5 6 1 3
2 4 5 6 1 3
1 2 4 5 6 3
1 2 3 4 5 6

Sample Input 2

3
1 2 3

Sample Output 2

1 2 3
1 2 3
1 2 3

题意: 输入n后,连续输入n个无序的整数 ,输出插入排序每一步的结果。


#include<bits/stdc++.h>typedef long long ll;using namespace std;int a[110];int main(){ios::sync_with_stdio(false);int n;cin>>n;for(int i = 1 ; i<=n ; i++){cin>>a[i];}for(int i = 1 ; i<=n ; i++){if(i == 1)cout<<a[i];elsecout<<" "<<a[i];}cout<<endl;//由小到大插入排序 for(int i = 2 ; i<=n ; i++){for(int j = 0 ; j<=i-1 ; j++){if(a[i]<a[j]){            //找到已经排序的序列中第一个比待插入元素大的 int t = a[i];for(int k = i ; k>=j+1 ; k--){    //把待插入大的都向后意一位 a[k] = a[k-1]; }a[j] = t;                         //插入空
break;
}
}
for(int j = 1 ; j<=n ; j++){
if(j == 1)
cout<<a[j];
else
cout<<" "<<a[j];
}
cout<<endl;
}
return 0;
}
  相关解决方案