当前位置: 代码迷 >> 综合 >> 1079 Total Sales of Supply Chain (25 分) DFS
  详细解决方案

1079 Total Sales of Supply Chain (25 分) DFS

热度:26   发布时间:2023-12-14 01:12:40.0

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤10^5), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N?1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K?j being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10^10
?? .

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

题意:给出树的总的结点的个数,和商品的起始单价,和经过每一层要涨的比例r,从根节点开始往下走,每层的价格都是父亲结点价格的(1+r%)倍,并且在输入的时候如果k等于0的话,就说明输入的是当前结点的值,题目给出了所有叶子结点的值,求他们的价格之和。
思路:不要被零售商,经销商,供应商这三者之间的关系弄乱了,其实就是算每个叶子结点在树的第几层即可,用dfs来把层数算好,把结点的子节点都遍历过去,算出结果。

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>using namespace std;double p,r;
double ans = 0.0;struct node {
    double data;vector<int> child;
};vector<node> v;void dfs(int index,int depth) {
    if(v[index].child.size() == 0) {
    ans = ans + v[index].data * pow(1 + r,depth);} for(int i = 0;i < v[index].child.size();i++) {
    dfs(v[index].child[i],depth + 1);}
}int main() {
    int n,k,x,c;scanf("%d%lf%lf",&n,&p,&r);r = r / 100;v.resize(n);for(int i = 0;i < n;i++) {
    scanf("%d",&k);if(k == 0) {
    scanf("%lf",&v[i].data);} else {
    for(int j = 0;j < k;j++) {
    scanf("%d",&x);v[i].child.push_back(x);}}}dfs(0,0);printf("%.1lf",ans * p);return 0;
} 
  相关解决方案