当前位置: 代码迷 >> 综合 >> PAT甲级-1024 Palindromic Number (25分)
  详细解决方案

PAT甲级-1024 Palindromic Number (25分)

热度:43   发布时间:2023-09-26 23:47:54.0

点击链接PAT甲级-AC全解汇总

题目:
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10?10?? ) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:
For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

题意:
输入一个数,判断是不是回文数,不是的话加上自己的逆序。
看有限次的这种操作后会不会是回文,如果不是也不再算了,直接输出。

注意: 如果用longlong 的话有两个case过不去,求和还是得自己写,不能用stoll转换成longlong求和。

我的代码:

#include<bits/stdc++.h>
using namespace std;string myadd(string str1,string str2)
{
    int jinwei=0;string res;for(int i=0;i<str1.length();i++){
    int num=str1[i]-'0'+str2[i]-'0'+jinwei;jinwei=num/10;num%=10;res.insert(0,to_string(num));}if(jinwei)res.insert(0,"1");return res;
}int main()
{
    int K,times=0;string num;cin>>num>>K;while(times<K){
    string num2(num.rbegin(),num.rend());if(num==num2){
    cout<<num<<endl<<times<<endl;return 0;}num=myadd(num,num2);times++;if(times==K)cout<<num<<endl<<times<<endl;}return 0;
}
  相关解决方案