当前位置: 代码迷 >> Java Web开发 >> hibernate3.6.5急需导入的包
  详细解决方案

hibernate3.6.5急需导入的包

热度:7161   发布时间:2013-02-25 21:16:54.0
hibernate3.6.5需要导入的包
是2.6.5的hibernate。运行的时候包的错误如下,知道是不是导jar包的问题。大家帮我看以下吧~
我导入的jar包有:
hibernate3.jar
antlr-2.7.6.jar
commons-collections-3.1.jar
dom4j-1.6.1.jar
javassist-3.12.0GA.jar
jta-1.1.jar
slf4j-api-1.6.1.jar
slf4j-nop-1.6.1.jar
除了这些还有数据库连接的jar包。


错误信息为:

Exception in thread "main" java.lang.NoClassDefFoundError: javax/persistence/EntityListeners
at org.hibernate.cfg.annotations.reflection.JPAMetadataProvider.getDefaults(JPAMetadataProvider.java:96)
at org.hibernate.annotations.common.reflection.java.JavaReflectionManager.getDefaults(JavaReflectionManager.java:226)
at org.hibernate.cfg.Configuration.secondPassCompile(Configuration.java:1385)
at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:1856)
at com.test.StudentTest.main(StudentTest.java:20)


------解决方案--------------------------------------------------------
你直接用myeclipse加载的 hibernate哇?那包应当是齐全的!
  相关解决方案
本站暂不开放注册!
内测阶段只得通过邀请码进行注册!
 
  • 最近登录:Wed Nov 21 16:13:49 CST 2018
  • 最近登录:Wed Nov 21 16:13:49 CST 2018
  • 最近登录:Wed Nov 21 16:13:49 CST 2018
  • 最近登录:Wed Nov 21 16:13:49 CST 2018
  • 最近登录:Wed Nov 21 16:13:49 CST 2018