当前位置: 代码迷 >> 综合 >> Happy Necklace [矩阵快速幂]
  详细解决方案

Happy Necklace [矩阵快速幂]

热度:22   发布时间:2023-11-22 14:01:53.0

题目链接
Problem Description
Little Q wants to buy a necklace for his girlfriend. Necklaces are single strings composed of multiple red and blue beads.
Little Q desperately wants to impress his girlfriend, he knows that she will like the necklace only if for every prime length continuous subsequence in the necklace, the number of red beads is not less than the number of blue beads.
Now Little Q wants to buy a necklace with exactly n beads. He wants to know the number of different necklaces that can make his girlfriend happy. Please write a program to help Little Q. Since the answer may be very large, please print the answer modulo 10^9+7.
Note: The necklace is a single string, { not a circle}.

Input
The first line of the input contains an integer T(1≤T≤10000), denoting the number of test cases.
For each test case, there is a single line containing an integer n(2≤n≤10^18), denoting the number of beads on the necklace.

Output
For each test case, print a single line containing a single integer, denoting the answer modulo 10^9+7.

Sample Input

2
2
3

Sample Output

3
4

代码:

递推公式: f[n] = f[n - 1] + f[n - 3];

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
struct matrix{
    long long int mat[4][4];
}A,B;
matrix mul(matrix a,matrix b){
    matrix tmp; memset(tmp.mat,0,sizeof(tmp.mat));for(int i = 0;i < 4;i++)for(int j = 0;j < 4;j++)for(int k = 0;k < 4;k++){
    tmp.mat[i][j] += a.mat[i][k] * b.mat[k][j];tmp.mat[i][j] %= 1000000007;}return tmp;
}
matrix pow_mat(matrix a,long long int n){
     //注意n 是long long int 类型,老写成int 类型matrix ans;int num = 0;memset(ans.mat,0,sizeof(ans.mat));for(int i = 0;i < 4;i++)ans.mat[i][i] = 1;while(n){
    if(n & 1)ans = mul(ans,a);a = mul(a,a);n >>= 1;}return ans;
}
int main(){
    long long int t,n;scanf("%lld",&t);while(t--){
    scanf("%lld",&n);if(n == 2){
    printf("3\n");continue;}else if(n == 3){
    printf("4\n");continue;}else if(n == 4){
    printf("6\n");continue;}else if(n == 5){
    printf("9\n");continue;}else{
    A.mat[0][0] = 3,A.mat[0][1] = 4,A.mat[0][2] = 6,A.mat[0][3] = 9;B.mat[0][0] = 0,B.mat[0][1] = 0,B.mat[0][2] = 1,B.mat[0][3] = 0;B.mat[1][0] = 1,B.mat[1][1] = 0,B.mat[1][2] = 0,B.mat[1][3] = 1;B.mat[2][0] = 0,B.mat[2][1] = 1,B.mat[2][2] = 1,B.mat[2][3] = 0;B.mat[3][0] = 0,B.mat[3][1] = 0,B.mat[3][2] = 0,B.mat[3][3] = 1;B = pow_mat(B,n - 5);printf("%lld\n",mul(A,B).mat[0][3]);}}return 0;
}
  相关解决方案