当前位置: 代码迷 >> 综合 >> Girls and Boys POJ - 1466(最大独立集)
  详细解决方案

Girls and Boys POJ - 1466(最大独立集)

热度:89   发布时间:2023-12-07 00:23:35.0

Girls and Boys POJ - 1466

In the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.InputThe input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students

the description of each student, in the following format

student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 …

or

student_identifier:(0)

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.OutputFor each given data set, the program should write to standard output a line containing the result.
Sample Input
7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output
5
2

题意:
在这里插入图片描述
题解:

由|最大独立集|+|最小顶点覆盖|=|V| 和 |最大匹配|=|最小顶点覆盖| 得到 |最大独立集|=|V|-|最大匹配|。

#include <cstdio>
#include <vector>
#include <algorithm>
#include <cstring>
using namespace std;const int MAX_K = 1e4 + 5;
const int MAX_V= 1e5 + 10;
vector<int> G[MAX_V];
int match[MAX_V];
bool used[MAX_V];
int N, K, V;
int R[MAX_K], C[MAX_K];void add_edge(int u, int v) {
    G[u].push_back(v);G[v].push_back(u);
}bool dfs(int v) {
    used[v] = true;for (int i = 0; i < G[v].size(); i++) {
    int u = G[v][i], w = match[u];if ( w < 0 || !used[w] && dfs(w)) {
    match[v] = u;match[u] = v;return true;}}return false;
}int bipartite_match() {
    int res = 0;memset(match, -1, sizeof(match));for (int v = 0; v < V; v++) {
    if (match[v] < 0) {
    memset(used, 0, sizeof(used));if(dfs(v)) {
    res++;}}}return res;
}void slove() {
    V = 2 * N;for (int i = 0; i < K; i++) {
    add_edge(R[i] - 1, N + C[i] - 1);}printf("%d\n",bipartite_match());
}int main() {
    while(scanf("%d", &V) != EOF) {
    for(int i = 0; i < V; i++) {
    G[i].clear();}for(int i = 0; i < V; i++) {
    int n;int s, t;scanf("%d: (%d)", &s, &n);for(int i = 0; i < n; i++) {
    scanf("%d", &t);add_edge(s, t);}}printf("%d\n", V - bipartite_match());}
}