当前位置: 代码迷 >> 综合 >> 06-图2 Saving James Bond - Easy Version(25 分)---DFS
  详细解决方案

06-图2 Saving James Bond - Easy Version(25 分)---DFS

热度:49   发布时间:2024-01-22 02:07:44.0
06-图2 Saving James Bond - Easy Version(25 分)

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integersN (100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No


题意分析:

  一个人被困在孤岛上,岛被水环绕着,水中有鳄鱼,给出鳄鱼的坐标,人一次能跳的距离,用鳄鱼做跳板,问最后能否上岸。和去年校赛的题有点类似,明天校赛不要太惨烈呀~。

标准的DFS!需要找出若干个第一跳!依次进行DFS.


#include<iostream>
#include<cstdio>
#include<vector>
#include<cmath>
#include<algorithm>
using namespace std;#define minl 42.5struct point {int x, y;bool vis;
};
int N, D;
vector<point>s;  
point o;
int flag;//是否能跳出去
double Distance(point a, point b)
{return sqrt(pow(a.x - b.x, 2) + pow(a.y - b.y, 2));
}void dfs(int i)
{s[i].vis = true;if (50 - abs(s[i].x) <= D || (50 - abs(s[i].y) <= D))flag = 1;for (int j = 0; j < N; j++)if (!s[j].vis&&Distance(s[i], s[j]) <= D)dfs(j);	
}int main()
{flag = 0;int i;	point p;vector<int>firstjump;cin >> N >> D;for (int i = 0; i < N; i++){cin >> p.x >> p.y;p.vis = false;s.push_back(p);}if (D >= minl) { cout << "Yes" << endl; return 0; }//直接飞出去啦for (int i = 0; i < N; i++)if (Distance(s[i], o) <= D + 7.5)firstjump.push_back(i);if (firstjump.empty()) { cout << "No" << endl; return 0; }//第一跳都没有for (int i = 0; i < firstjump.size(); i++)dfs(firstjump[i]);if(flag)		cout << "Yes" << endl;else cout << "No" << endl;system("pause");
}


  相关解决方案