当前位置: 代码迷 >> 综合 >> PAT甲级-1060 Are They Equal (25分)
  详细解决方案

PAT甲级-1060 Are They Equal (25分)

热度:66   发布时间:2023-09-26 23:15:03.0

点击链接PAT甲级-AC全解汇总

题目:
If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10?5?? with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10?100?? , and that its total digit number is less than 100.

Output Specification:
For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

题意:
判断在k位有效位的时候科学记数法的表达是否一样

算法笔记的代码:

#include<cstdio>
#include<iostream>
#include<string>
using namespace std;
int n;
string deal(string s,int& e){
    int k=0;while(s.length()>0&&s[0]=='0'){
    s.erase(s.begin());}if(s[0]=='.'){
                           // 0.***s.erase(s.begin());while(s.length()>0&&s[0]=='0'){
     // 0.000***s.erase(s.begin());e--;}                               // ->0.000[***]}else{
                                  // ***.***while(k<s.length()&&s[k]!='.'){
    k++;e++;}                           // ***.***if(k<s.length()){
               // s[k]=='.'s.erase(s.begin()+k);}                           //[***].[***]}if(s.length()==0){
    e=0;}                               // 0.0int num=0;k=0;string res;while(num<n){
    if(k<s.length())    //还有非零数res+=s[k++];else                //用零补齐res+='0';num++;              //有效位}return res;
}
int main(){
    string s1,s2,s11,s22;cin>>n>>s1>>s2;int e1=0,e2=0;s11=deal(s1,e1);s22=deal(s2,e2);if(s11==s22&&e1==e2){
    cout<<"YES 0."<<s11<<"*10^"<<e1<<endl;}else{
    cout<<"NO 0."<<s11<<"*10^"<<e1<<" 0."<<s22<<"*10^"<<e2<<endl;}return 0;
}
  相关解决方案