当前位置: 代码迷 >> 综合 >> PAT甲级-1030 Travel Plan (30分)
  详细解决方案

PAT甲级-1030 Travel Plan (30分)

热度:62   发布时间:2023-09-26 23:42:43.0

点击链接PAT甲级-AC全解汇总

题目:
A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N?1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:
For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

题意:
求最短路径,路径相同则选择最小花费;
(被上一道30分摩擦的景象还历历在目,这道30分题是目前遇到最简单的了。。一次编译一次提交竟然直接AC了!)

我的代码:

#include<bits/stdc++.h>
using namespace std;
#define MAX_NUM 520int N,M,S,D;
int DIS[MAX_NUM][MAX_NUM]={
    0};
int COST[MAX_NUM][MAX_NUM]={
    0};
bool visited[MAX_NUM]={
    false};queue<int>shortest_path;
int min_dis=INT_MAX,min_cost=INT_MAX;void DFS(int start,int now_dis,int now_cost,queue<int> now_path){
    now_path.push(start);if(start==D){
    if(now_dis<min_dis){
    min_dis=now_dis;min_cost=now_cost;shortest_path=now_path;}else if(now_dis==min_dis&&now_cost<min_cost){
    min_dis=now_dis;min_cost=now_cost;shortest_path=now_path;}}else{
    for(int i=0;i<N;i++){
    if(!visited[i]&&DIS[start][i]){
    visited[i]=true;now_dis+=DIS[start][i];now_cost+=COST[start][i];DFS(i,now_dis,now_cost,now_path);visited[i]=false;now_dis-=DIS[start][i];now_cost-=COST[start][i];}}}
}int main()
{
    cin>>N>>M>>S>>D;for(int i=0;i<M;i++){
    int a,b,dis,cost;cin>>a>>b>>dis>>cost;DIS[a][b]=dis;DIS[b][a]=dis;COST[a][b]=cost;COST[b][a]=cost;}visited[S]=true;queue<int>q;DFS(S,0,0,q);while(shortest_path.size()){
    cout<<shortest_path.front()<<" ";shortest_path.pop();}cout<<min_dis<<" "<<min_cost<<endl;return 0;
}