当前位置: 代码迷 >> 综合 >> PAT - 甲级 - 1091. Acute Stroke (30)(三维BFS)
  详细解决方案

PAT - 甲级 - 1091. Acute Stroke (30)(三维BFS)

热度:106   发布时间:2023-10-09 14:03:36.0

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M by N matrix, and the maximum resolution is 1286 by 128); L (<=60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M by N matrix of 0's and 1's, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1's to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are "connected" and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.


Figure 1

Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:
3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0
Sample Output:
26

给定条件:
1.l个m*n的01矩阵
2.连通条件:

1.因为是三维空间,所有连通方向有前、后、左、右、上、下六个方向
2.如图所示,蓝色和六个红色连通

要求:
1.每个总和大于t的所有连通块的和

求解:
1.求连通块可以用DFS和BFS,下面给出两种做法
2.其中DFS由于递归深度过大,最后两个测试点导致段错误


BFS

#include <cstdio>
#include <algorithm>
#include <queue>
using namespace std;struct Pixels {int x, y, z;int value;
} pixel;vector<Pixels> v;
int m, n, l, t, temp, tot, ans = 0;int vis[65][1300][130];
int matrix[65][1300][130];int dirX[6] = {0, 0, 0, 0, 1, -1};
int dirY[6] = {0, 0, 1, -1, 0, 0};
int dirZ[6] = {1, -1, 0, 0, 0, 0};bool judge(int x, int y, int z) {if(x < 0 || y < 0 || z < 0) return false;if(x == l || y == m || z == n) return false;if(matrix[x][y][z] == 0) return false;if(vis[x][y][z] == true) return false;vis[x][y][z] = true;pixel.x = x;pixel.y = y;pixel.z = z;pixel.value = 1;return true;
}void bfs(Pixels p) {queue<Pixels> q;q.push(p);while(!q.empty()) {Pixels front = q.front();tot += front.value;for(int i = 0; i < 6; i++) {int xx = front.x + dirX[i];int yy = front.y + dirY[i];int zz = front.z + dirZ[i];if(judge(xx, yy, zz) == true) {q.push(pixel);}}q.pop();}
}int main() {scanf("%d%d%d%d", &m, &n, &l, &t);for(int i = 0; i < l; i++) {for(int j = 0; j < m; j++) {for(int k = 0; k < n; k++) {scanf("%d", &matrix[i][j][k]);vis[i][j][k] = 0;}}}for(int i = 0; i < l; i++) {for(int j = 0; j < m; j++) {for(int k = 0; k < n; k++) {if(matrix[i][j][k] == 1 && vis[i][j][k] == 0) {tot = 0;pixel.x = i; pixel.y = j; pixel.z = k; pixel.value = 1;vis[i][j][k] = 1;bfs(pixel);ans += tot >= t ? tot : 0;}}}}printf("%d\n", ans);return 0;
}

DFS

#include <cstdio>
#include <algorithm>using namespace std;int m, n, l, t, temp, tot, ans = 0;
int matrix[65][1300][130];
int vis[65][1300][130];void dfs(int i, int j, int k) {if(i < 0 || i == l) return ;if(j < 0 || j == m) return ;if(k < 0 || k == n) return ;if(vis[i][j][k] == 1) return ;if(matrix[i][j][k] == 0) return ;tot += matrix[i][j][k];vis[i][j][k] = 1;dfs(i+1, j, k);dfs(i-1, j, k);dfs(i, j+1, k);dfs(i, j-1, k);dfs(i, j, k+1);dfs(i, j, k-1);}int main() {freopen("input.txt", "r", stdin);scanf("%d%d%d%d", &m, &n, &l, &t);for(int i = 0; i < l; i++) {for(int j = 0; j < m; j++) {for(int k = 0; k < n; k++) {scanf("%d", &matrix[i][j][k]);vis[i][j][k] = 0;}}}for(int i = 0; i < l; i++) {for(int j = 0; j < m; j++) {for(int k = 0; k < n; k++) {if(!vis[i][j][k] && matrix[i][j][k] == 1) {tot = 0;dfs(i, j, k);ans +=  tot >= t ? tot : 0;}}}}printf("%d\n", ans);return 0;
}