全排列
给出一个字符串S(可能有重复的字符),按照字典序从小到大,输出S包括的字符组成的所有排列。
例如:S = "1312",
输出为:
1123
1132
1213
1231
1312
1321
2113
2131
2311
3112
3121
3211
Input
输入一个字符串S(S的长度 <= 9,且只包括0 - 9的阿拉伯数字)
Output
输出S所包含的字符组成的所有排列
Sample Input
1312
Sample Output
1123
1132
1213
1231
1312
1321
2113
2131
2311
3112
3121
3211
题意:
找到所有的组合,要注意的是会有重复的数字。
dfs代码:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
char s[11];
int vis[11];
char c[11];
void dfs(int step)
{ if(step==strlen(s)){printf("%s\n",c);return;}for(int i=0;i<strlen(s);i++){if(vis[i]==0){int j;for(j=i+1;j<strlen(s);j++) {//如果有重复的字符,并且那个字符已经标记,就停止对这个字符进行深搜 if(vis[j]&&s[j]==s[i]) {break;}}if(j==strlen(s)){c[step]=s[i];vis[i]=1;dfs(step+1);vis[i]=0;}}}return;
}
int main()
{scanf("%s",s);sort(s,s+strlen(s)); //对字符串从小到大排序 memset(vis,0,sizeof(vis));dfs(0); return 0;
}
STL - next_permutation函数代码:
#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{char a[11];scanf ("%s",a);int l = strlen(a);sort(a,a+l);do{printf ("%s\n",a);}while (next_permutation(a,a+l));return 0;
}