当前位置: 代码迷 >> 综合 >> PAT---A1027. Colors in Mars (20)
  详细解决方案

PAT---A1027. Colors in Mars (20)

热度:1   发布时间:2023-12-15 04:07:54.0

题目要求:
People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.

Sample Input
15 43 71
Sample Output

#123456

参考代码:

#include <cstdio>
char radix[13] = {
   '0','1','2','3','4','5','6','7','8','9','A','B','C'};
int main()
{int r,g,b;scanf("%d%d%d",&r,&g,&b);printf("#");printf("%c%c",radix[r/13],radix[r%13]);printf("%c%c",radix[g/13],radix[g%13]);printf("%c%c",radix[b/13],radix[b%13]);return 0;
}

还有一种答案,本人苦苦无法找寻错误,望各位看官能够给予建议:

#include <iostream>
using namespace std;
int main()
{for(int j=0;j<3;j++){int a;int i=0;int b[3] = {
   0};cin >>a;if(a==0){b[i] = 0;i = 1;}while(a){b[i] = a%13;a = a/13;i++;}if(j==0)cout <<"#";for(int j=0;j<i;j++){if((b[i-1-j]>=0)&&(b[i-1-j]<10))cout << b[i-1-j];else{switch(b[i-1-j]){case 10:cout <<"A";break;case 11:cout <<"B";break;case 12:cout <<"C";break;}}}}return 0;
}