当前位置: 代码迷 >> 综合 >> [PAT A1044]Shopping in Mars
  详细解决方案

[PAT A1044]Shopping in Mars

热度:23   发布时间:2023-12-15 06:17:21.0

[PAT A1044]Shopping in Mars

题目描述

1044 Shopping in Mars (25 分)Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1.Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2.Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3.Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.
If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

输入格式

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10?5??), the total number of diamonds on the chain, and M (≤10?8??), the amount that the customer has to pay. Then the next line contains N positive numbers D?1???D?N?? (D?i??≤10?3?? for all i=1,?,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

输出格式

For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.
If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj>M with (Di + … + Dj ?M) minimized. Again all the solutions must be printed in increasing order of i.
It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

输入样例1

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

输出样例1

1-5
4-6
7-8
11-11

输入样例2

5 13
2 4 5 7 9

输出样例2

2-4
4-5

解析

  1. 题目的大致意思就是输入一n和m,然后输入n个数,问是否存在连续的k个数,是的这k个数之和为m,如果不存在,找到大于m的数中最小的数,输出能相加等于它的组合
  2. 我的思路是使用数列存储它们的和,这样其中某一段的和只需要使用数列的后面某项减去前面某项即可,首先找到是否存在一段使得它们的和为m,如果不存在那我们就找到最小的大于m的数。
#include<iostream>
#include<string>
#include<vector>
using namespace std;
int main()
{
    vector<long long>v;long long temp = 0;long long n,m;scanf("%lld%lld", &n, &m);v.push_back(0);for (int i = 0; i < n; i++) {
    long long t;scanf("%lld", &t);v.push_back(temp + t);temp += t;}temp = LLONG_MAX;    //temp是我们要找的数,这里先使得temp为最大,后面在慢慢找for (int i = 0, j = 0; i <= j && i <= n&&j <= n;) {
    if (v[j] - v[i] < m)j++;    //如果这个数比m小,说明不够大,j++使得它多了一项else if (v[j] - v[i] > m) {
     //如果这个数比m大,说明当前这段长了,所以使i++,让它短一些if (v[j] - v[i] < temp) {
    temp = v[j] - v[i];}i++;}else {
        //这就是我们找到了一段,它的和为m,故我们可以立即停止,不用找了temp = m;break;}}for (int i = 0, j = 0; i <= j && i <= n&&j <= n;) {
    if (v[j] - v[i] == temp) {
    printf("%d-%d\n", i + 1, j);i++;}else if (v[j] - v[i] < temp) j++;else i++;}return 0;
}

水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位提出宝贵的意见!