当前位置: 代码迷 >> 综合 >> PAT甲级-1037 Magic Coupon (25分)
  详细解决方案

PAT甲级-1037 Magic Coupon (25分)

热度:52   发布时间:2023-09-26 23:36:16.0

点击链接PAT甲级-AC全解汇总

题目:
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 ?1 }, and a set of product values { 7 6 ?2 ?3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons N?C?? , followed by a line with N?C?? coupon integers. Then the next line contains the number of products N?P?? , followed by a line with N?P?? product values. Here 1≤N?C?? ,N?P?? ≤10?5?? , and it is guaranteed that all the numbers will not exceed 2?30?? .

Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

题意:
求两组数各挑一个数相乘的和最大,每个数只能用一次,可以不用

我的思路:
把所有正数从大到小排,大的乘大的求和;
把所有负数从小到大排,小的乘小的求和;
剩下一正一负就算了,求和反而变小了。

我的代码:

#include<bits/stdc++.h>
using namespace std;int main(){
    vector<int>coupon_p,coupon_n;vector<int>product_p,product_n;int N;cin>>N;for(int i=0;i<N;i++){
    int t;cin>>t;if(t>0)coupon_p.push_back(t);else coupon_n.push_back(t);}cin>>N;for(int i=0;i<N;i++){
    int t;cin>>t;if(t>0)product_p.push_back(t);else product_n.push_back(t);}sort(coupon_p.begin(),coupon_p.end(),greater<int>());sort(coupon_n.begin(),coupon_n.end());sort(product_p.begin(),product_p.end(),greater<int>());sort(product_n.begin(),product_n.end());int ans=0;for(int i=0;i<min(coupon_p.size(),product_p.size());i++){
    ans+=coupon_p[i]*product_p[i];}for(int i=0;i<min(coupon_n.size(),product_n.size());i++){
    ans+=coupon_n[i]*product_n[i];}cout<<ans<<endl;return 0;
}
  相关解决方案