当前位置: 代码迷 >> 综合 >> Seek the Name, Seek the Fame(求一个字符串拥有所有相等的前后缀)
  详细解决方案

Seek the Name, Seek the Fame(求一个字符串拥有所有相等的前后缀)

热度:45   发布时间:2023-11-22 01:49:49.0

题目链接poj2752

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:
Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).
Example: Father=‘ala’, Mother=‘la’, we have S = ‘ala’+‘la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

.For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

从i=next[len]开始,如果next[len]==0则该字符串没有公共前后缀,如果next[len]存在数值,则for循环下次从i=next[i]开始寻找更小的一个公共前后缀

a b a a c c a b a a
0 0 1 1 0 0 1 2 3 4

以上面的列表为例(next数组从next[1]开始,next[0]=0省略), next[10] = 4(及前缀abaa=后缀abaa)然后从i=next[10]开始i=4,next[4]=1(及前缀a=后缀a),然后next[1]==0结束循环

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#define N 400010
using namespace std;
char str[N];
int nextt[N];
void getnext(char *s,int slen)
{
    nextt[0]=0;nextt[1]=0;for(int i=1;i<slen;i++){
    int j=nextt[i];while(j&&s[i]!=s[j]) j=nextt[j];nextt[i+1] = (s[i]==s[j])?j+1:0;}
}
int main()
{
    while(~scanf("%s",&str)){
    int cnt[N];int num=0;memset(cnt,0,sizeof(cnt));memset(nextt,0,sizeof(nextt));int slen = strlen(str);getnext(str,slen);for(int i=slen;i>0;i=nextt[i]){
    if(nextt[i]){
    cnt[num] = nextt[i];num++;}}for(int i=num-1;i>=0;i--)printf("%d ",cnt[i]);printf("%d\n",slen);}}