业务场景:
接受或者生成日志给kafka队列 消费者同步入库
公司最近业务日志比较多 于是设计通过MQ传输消费
设计的自作多情的时候为了减少通信 会把日志归并(使用阻塞队列汇集达到100+再发送出去)结果就是出现大规模的消息堆积在kafka里面
解决:
前面既然说了是自作多情,问题也就在这。大消息发送没问题,但是在消费的时候出现了问题。业务日志显示在频繁的拉取同一条消息,重复的消费。
原因:消费超时。kafka一次性拉取近500条消息。60秒内消费不完就会超时。导致消费不成功。也就有了后面的重复消费。
这一类业务的正确处理是这样的,直接单条记录单条消息发送,kafka自己会做消息的归并达到一定的量才会发送。消费也是如此。
详细解决方案
kafka 消息重复拉取消费超时
热度:148 发布时间:2023-09-13 09:00:55.0
相关解决方案
- Kafka 保证分区有序
- kafka 消息重复拉取消费超时
- 黑猴子的家:kafka.sh
- Linux Kafka 创建Topic 命令
- Kafka shell基本操作
- sparkStreaming 消费 kafka 一直显示offset提交失败 Offsetcommit failed
- Kafka topic分区设置不合理导致磁盘写入不均衡
- kafka 分布式(不是单机)的情况下,如何保证消息的顺序消费?
- kafka-4、zookeeper、kafka、kafka-manager配置服务自启动
- Kafka Consumer介绍
- Kafka Producer介绍
- Java 最常见的 208 道面试题:第十五模块答案 Kafka
- org.apache.kafka.streams.errors.InvalidStateStoreException
- kafka connect中连接oracle出错:No suitable driver found for
- kafka topic手动删除及其他相关
- kafka 监控系列kafka manager
- 【Apache Kafka】设计理念浅析
- flume kafka storm
- kafka 高吞吐、高并发架构
- redis rabbitmq kafka beanstalkd比较
- 基于canal+kafka+flink的实时增量同步功能2:消费者kafkaTomysql代码实现
- 读书笔记-kafka常用操作命令-kafka-topics.sh
- Kafka | bin/Command
- Kafka | Flume Sink日志到KafkaHDFS
- 大数据技术之Kafka 第6章 kafka Streams
- Kafka 整体介绍
- Kafka mirror实践
- kafka - Producer acks应答
- kafka _schema topic 损坏问题WARN The replication factor of the schema topic _schemas is less than
- Docker 与 kafka