当前位置: 代码迷 >> 综合 >> HDOJ 1084 What Is Your Grade?
  详细解决方案

HDOJ 1084 What Is Your Grade?

热度:96   发布时间:2023-10-13 22:43:58.0

What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10759    Accepted Submission(s): 3341


Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!
 
Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 
Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 

Sample Input
   
4 5 06:30:17 4 07:31:27 4 08:12:12 4 05:23:13 1 5 06:30:17 -1
 
Sample Output
   
100 90 90 95100
 主要用结构体排序,具体还得想;
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{int list;int n;int grades;int time;
}a[110];
int cmp1(node x,node y)
{if(x.n!=y.n)return x.n>y.n;elsereturn x.time<y.time;
}
int cmp2(node x,node y)
{return x.list<y.list;
}
int main()
{int n,i,j;int num[6];//记录做对同样数目题的人数 while(scanf("%d",&n)&&(n>0)){memset(num,0,sizeof(num));for(i=0;i<n;i++){int h,m,s;scanf("%d %d:%d:%d",&a[i].n,&h,&m,&s);a[i].time=3600*h+60*m+s;a[i].list=i;a[i].grades=50+a[i].n*10;num[a[i].n]++;}sort(a,a+n,cmp1);num[1]/=2;//看做对同样数目的题人中排在 前一半的人数; num[2]/=2;num[3]/=2;num[4]/=2;for(i=0,j=4;i<n;i++){if(a[i].n==0||a[i].n==5)continue;j=a[i].n;if(num[j]==0)continue;else{a[i].grades+=5;//排在前一半的人加分 num[j]--;}} sort(a,a+n,cmp2);for(i=0;i<n;i++)printf("%d\n",a[i].grades);printf("\n");}return 0;
}



  相关解决方案